CaseMark web app error
Incident Report for CaseMark
Postmortem

On November 8, 2024, at 17:06:54 GMT (roughly 9am PST), our product became unavailable for a total of 2 hours and 10 minutes due to a lapse in SSL certificate renewal. This lapse occurred because the certificate renewal process was not automated and was therefore prone to human error.

The lapse in SSL certificate renewal resulted in a significant disruption of service for our users. During the outage, users were unable to access our website or use our products and services.

In response to this incident, we have taken steps to automate the SSL certificate creation and deployment process. This will ensure that our certificates are renewed in a timely manner and that our products and services remain available to our users.

We are also investing in additional security measures to prevent similar incidents from occurring in the future. We are committed to providing our users with a safe and secure experience and we will continue to work to improve our security practices.

We apologize for any inconvenience caused by this incident and we appreciate our users' patience and understanding.

Posted Nov 13, 2024 - 14:15 PST

Resolved
This incident has been resolved.
Posted Nov 08, 2024 - 11:16 PST
Update
We have deployed the fix to the problem we were experiencing and have restored the service to normal operation. We have further identified some additional improvements during our investigation that we will soon be deploying to improve site reliability.

Please accept our apologies for the disruption.
Posted Nov 08, 2024 - 11:15 PST
Identified
We've identified the root cause of this issue and are now deploying a fix.
Posted Nov 08, 2024 - 10:51 PST
Investigating
We are currently investigating an issue that is causing the CaseMark web app to display a 502 error. Our Engineering team is currently working on the issue.
Posted Nov 08, 2024 - 09:21 PST
This incident affected: CaseMark Workflow.